Authentication failures
Incident Report for MailChannels Cloud
Resolved
We identified that the elevated error rates were caused due to a failed deployment. We have reverted the deployment to a known good configuration. There should be no errors at the moment.

If you are experiencing any issues, please contact support@mailchannels.com
Posted 6 days ago. Jul 09, 2019 - 16:24 PDT
Investigating
We are currently investigating elevated error rates on our inbound filtering service. Some customers are reporting relay errors in the form "554 5.7.1 : Relay access denied".
Posted 6 days ago. Jul 09, 2019 - 15:22 PDT
This incident affected: MailChannels Inbound Filtering - SMTP Service.