Outbound Cloud Console Degraded Performance
Incident Report for MailChannels Cloud
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted 10 days ago. Jun 05, 2019 - 18:48 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted 10 days ago. Jun 05, 2019 - 18:42 PDT
This incident affected: MailChannels Host Console.