DNS issues at service provider
Incident Report for MailChannels
Resolved
We identified and fixed the DNS issue. The platform has been stable for the last few hours. Mails that were queues have all been drained out. We will provide a more detailed report in the next couple of days about the issue. If you are still seeing any issues, please contact support@mailchannels.com
Posted Feb 18, 2017 - 07:14 PST
Identified
The DNS issue is still not completely resolved. We are working on getting this fixed.
Posted Feb 17, 2017 - 21:07 PST
Monitoring
We have now identified and fixed the DNS issue that caused today's failure. We are working with our service provider to ensure that this kind of issue does not happen again. We are continuing to monitor the situation. If there are mails in your queue, you may want to flush the queue. In case of any issues, please contact support@mailchannels.com
Posted Feb 17, 2017 - 19:46 PST
Identified
Our service provider is experiencing DNS issues. This has resulted in degraded performance of our email platform. You might experience intermittent authentication failures as a result of this. We are working on getting this resolved. We will update the status as we work through the issue.
Posted Feb 17, 2017 - 13:56 PST