Increase in False Positives
Incident Report for MailChannels Cloud
Resolved
An immediate fix has been deployed. All .co.uk domains are being delivered now through the service.
Posted 5 months ago. May 07, 2019 - 10:53 PDT
Update
We have received reports that some .co.uk domains are still being inappropriately blocked. We are rolling out immediate updates to fix this.
Posted 5 months ago. May 07, 2019 - 10:38 PDT
Monitoring
For 27 minutes today, ending at approximately 8:30 Pacific Time (San Francisco), an error in our spam filtering system erroneously blocked all messages with a destination address ending in “.co.uk”. We are working on a fix.

We sincerely apologize to our customers for the inconvenience.
Posted 5 months ago. May 07, 2019 - 09:14 PDT
This incident affected: MailChannels Outbound Filtering - SMTP Service.