Outbound Cloud Console Degraded Performance
Incident Report for MailChannels Cloud
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted 3 months ago. Jun 19, 2019 - 18:07 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted 3 months ago. Jun 19, 2019 - 17:28 PDT
This incident affected: MailChannels Host Console.