Outbound Cloud Console Degraded Performance
Incident Report for MailChannels Cloud
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted Feb 06, 2020 - 21:12 PST
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted Feb 06, 2020 - 21:05 PST
This incident affected: MailChannels Host Console.