Outbound Cloud Console Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted Mar 05, 2020 - 17:34 PST
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted Mar 05, 2020 - 17:03 PST
This incident affected: Outbound Filtering (Host Console).