SMTP Service Degraded Performance
Incident Report for MailChannels Cloud
Resolved
This incident has been resolved.
Posted Nov 08, 2019 - 14:06 PST
Update
Queue sizes have returned to normal, messages should now be delivered quickly. We're continuing to monitor while we work with our service providers to identify the root cause.
Posted Nov 08, 2019 - 11:50 PST
Monitoring
A network problem was causing a large number of connections to downstream destination servers to time out. The problem appears to have been resolved. We are in contact with our networking provider to identify a root cause, and we are continuing to monitor the situation.

No messages have been lost. It may take some time to deliver all of the currently queued messages. We will update this incident when delivery delay times are back to normal.
Posted Nov 08, 2019 - 11:26 PST
Investigating
We are currently experiencing a degraded performance in our Mailchannels Cloud SMTP service.

Our operations team is working to identify the root cause and implement a solution. Mail is still being delivered, but messages may be delayed.

We will send an additional update in 60 minutes or as soon as we have more information to share.
Posted Nov 08, 2019 - 11:02 PST
This incident affected: MailChannels Outbound Filtering - SMTP Service.