Reseller API Degradation
Incident Report for MailChannels Cloud
Resolved
This incident has been resolved.
Posted about 2 months ago. Mar 08, 2017 - 17:30 PST
Investigating
Our automated systems have detected possible performance issues with the Reseller API. We are currently investigating and will provide an update soon.
Posted about 2 months ago. Mar 08, 2017 - 15:18 PST