Delay on processing Inbound Mail
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Feb 18, 2021 - 14:07 PST
Investigating
We are currently investigating this issue.
Posted Feb 18, 2021 - 13:39 PST
This incident affected: Inbound Filtering (SMTP Service).