Outbound Cloud Console Degraded Performance
Incident Report for MailChannels
Resolved
We have identified and fixed the issues with the outbound cloud console.
Posted Aug 05, 2021 - 19:31 PDT
Investigating
Severity Level: 3

Our automated systems have detected possible performance problems with the outbound cloud console. We are currently investigating.
Posted Aug 05, 2021 - 18:29 PDT
This incident affected: Outbound Filtering (Host Console).