3rd party connection issues
Incident Report for MailChannels
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 12:49 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 05, 2022 - 12:26 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 05, 2022 - 12:07 PST
This incident affected: Inbound Filtering (SMTP Service) and Outbound Filtering (SMTP Service).