Issue with certain components of the system
Incident Report for MailChannels
Resolved
We experienced a brief outage of certain components that may result in some mails being rejected. The issue is now fixed.

If there are any rejected mails, please resend the mails.

If you have any questions, please contact us at support@mailchannels.com
Posted Apr 25, 2016 - 14:01 PDT